Menu Home

Swapped out the system board

Earlier this week I received the replacement system board from Dell for my XPS 700.

The old system board was not always starting up. Sometimes it would take 4 false starts to get it to boot up; it it was more than 3 I usually just gave up and went to bed.

The new board came in an anti-static bag with one cleaning pad and conductive paste.

XPS replacement system board

The system board is attached to a plate that is held in by two screws. Once you get the cables put aside it’s straight forward to remove or install the system. Alek used the cleaning pad to make the top of the CPU spotless. The heat sink shined.

IMG_0640

After the system was plugged in and running the fun began. The system would start and stop all without a hitch. That problem was completely solved. But the BIOS was not keeping the raid configuration, so the system could not boot.

I called the direct number I was given last week. I put in the extension and found out that my contacts voice mail was full. I could not even leave a message so I tried the general support line. While waiting I noticed that the BIOS was version 0.1.2 dated 5/5/06.

That did not fill me with confidence since the old system board was 1.1.3. After going around in circles, I unplugged the power, looked in the case at the connectors, and poof it started booting. I flashed the BIOS with the support person on the phone and all seems well now.

I’m going to call up the shipper and have the old system board picked up. In the meanwhile I’ll be pounding on the XPS 700 to make sure that it’s all good.

Categories: Geek

Tagged as:

Jan Dembowski